DRIVE BY WIRE PEDAL PROBLEMS!!!

Anything to do with the LS1 and the variants.

Moderators: Super Mod, Moderators

DRIVE BY WIRE PEDAL PROBLEMS!!!

Postby jbabb4057 » Sat Apr 01, 2017 7:16 pm

I have been reading these forums for quite a while gathering info for my swap and let me start by saying thanks to all the people who post here so guys like me can get into this. Now, I am putting a 5.3/t56 into a 1998 Sonoma. I am using Current Performance mounts, shorty headers, harness, and radiator. The motor is in, mostly wired, and still has the front end off of it now while I wait on the radiator to arrive. I am running into a few problems though, mainly the drive by wire pedal my motor came with.

The motor that I'm swapping into my Sonoma is a 5.3 from either 2005 or 2006, I'm not positive which it is. It is drive by wire and I have gotten to the point where I need to mount a pedal into the cab. The pedal that it came with is the huge plastic pedal that swoops way out to the right. That just isn't going to work, period. I did get ahold of a 98 corvette pedal and at first thought that this would work with the truck TAC but after alot of searching I'm now thinking it won't. I have searched and read and read until I've confused myself. I know I'll need to have the computer tuned for a different pedal and thats fine, the computer is at Texas Speed right now. I just need to know what will work. I have a harness from Current Performance. I have read that Jared would be the man to know about this but he must be a very busy man because he is hard to get ahold of. Someone out there has to have done this before, so how did you do it? Thanks for any insight in advance...
jbabb4057
I found rocker arm monkey's on ebay!
 
Posts: 6
Joined: Sun Mar 05, 2017 10:06 pm

Re: DRIVE BY WIRE PEDAL PROBLEMS!!!

Postby SleeperSS » Sun Apr 02, 2017 12:11 am

I don't know much about dbw, but moon509 at S10 forum does. He worked out similar problems with mixed/matched components.
'96 Apple Red SS...
'02 Pewter Blazer 2


U.S.C.G. "So others may live"
User avatar
SleeperSS
I drink used anti-freeze
 
Posts: 736
Joined: Mon Jan 01, 2007 7:29 pm
Location: Spanaway, Wa

Re: DRIVE BY WIRE PEDAL PROBLEMS!!!

Postby jbabb4057 » Sun Apr 02, 2017 10:13 am

Ok thanks, I'll shoot him a message and see if I can get any help. Anybody else?
jbabb4057
I found rocker arm monkey's on ebay!
 
Posts: 6
Joined: Sun Mar 05, 2017 10:06 pm


Return to LSx Tech

Who is online

Users browsing this forum: No registered users and 1 guest

cron